Soundbrenner wearables compatibility

The Soundbrenner Pulse and Soundbrenner Core need to be activated in our companion app “The Metronome by Soundbrenner”. To establish a connection, your smartphone or tablet require at least Bluetooth 4.0 (also called Bluetooth LE or Bluetooth Smart) as well as iOS 11 (and later) or Android 5 (and later).

Compatible iOS devices

All iOS devices that are compatible with iOS 11:

  • iPhone 5s and later
  • iPod touch (6th generation) and later
  • iPad (5th generation) and later

Compatible Android devices

Most Android smartphones and tablets that were released in 2014 and later will be compatible with Bluetooth 4.0 and support Android 5 and later. If you are not sure whether your device is compatible, feel free to contact our support. We would love to hear from you!

Contact support

Some Android devices may experience issues with Soundbrenner wearables due to low processing power or weak Bluetooth hardware:

  • Sony (It's currently not possible to update the firmware of Core with a Sony device. Since Core firmware updates are infrequent, we recommend to borrow a mobile device from a spouse or friend to perform them.)
  • Huawei P8 Lite (in general many Huawei mobile devices can only connect up to 3 Bluetooth devices, so you might experience limited multi-player synchronization capabilities.)
  • Xiaomi (Some Xiaomi users have reported irregularities with receiving smartphone notifications on their Core.)
  • Oppo (Some Oppo users have reported irregularities with receiving smartphone notifications on their Core.)
  • Vivo (Some Vivo users have reported irregularities with receiving smartphone notifications on their Core.)
  • Redmi

DAW compatibility

To learn more about how to sync our wearables with DAWs, please go here:

Setup guide

Was this article helpful?
1 out of 1 found this helpful
Contact support

Articles in this section

Sections